Cisco 명령어 정리
오늘은 Cisco 명령을 정리해보려고 합니다. 제가 다니는 회사는 현재 L3에 대한 유지보수를 맺지 않아 장애가 터졌을 시 확인 해야 할 부분을 대비하기 위한 정리입니다. 앞으로는 다른 형식으로 유지보수로 업무기안을 올린 상태지만 우리같은 담당자들은... 대비를 해야합니다. 그런 의미로 정리를 하였습니다.
Cisco router 명령어 정리
1. 라우터 이름 설정
borisrouter#conf t
borisrouter(config)#hostname boris
2. 관리 비밀번호 설정
borisrouter(config)#enable secret (원하는 패스워드 boris)
enable password (원하는 패스워드 boris)
3. 텔넷 비밀번호 설정
borisrouter(config)#line vty 0 4
borisrouter(config-line)#login
borisrouter(config-line)#password cisco
4. 텔넷 연결 세션 보기
borisrouter#show session
5. 세션 종료
borisrouter#disconnect
6. 라우터 IP 설정
borisrouter#conf t
borisrouter(config)#interface fa 0/0
borisrouter(config-if)#ip address 100.100.100.254 255.255.255.0
7. 포트 동작 시키기
borisrouter(config-if)#no shutdown
8. VLAN 1 및 IP 설정
borisrouter(config)interface fastEthernet 0/0.1
borisrouter(config-subif)encapsulation dot1Q 1 native
borisrouter(config-subif)ip address 200.2000.200.254 255.255.255.0
9. IPX 동작 시키기
borisrouter#conf t
borisrouter(config)#ipx routing
interface fa 0/0
borisrouter(config-if)#ipx network 1
10. IGRP 라우팅 프로토콜
borisrouter(config)#borisrouter igrp 200
borisrouter(config-router)#network 172.20.0.0
borisrouter(config-router)#network 10.10.0.0
11. NVRAM으로 저장
borisrouter#write memory
copy running-config startup-config
12. 스태틱 라우팅
borisrouter(config)#ip route 100.100.0.0 255.255.255.0 10.10.10.3
borisrouter(config)#ip route 150.150.0.0 255.255.0.0 serial 0
13. 디폴트 라우트
borisrouter(config)#ip default-network 10.10.10.254
14. 스태틱으로 디폴트 구현
borisrouter(config)#ip route 0.0.0.0 0.0.0.0 10.10.10.254
15. 텔넷 유저까지 설정
borisrouter(config)#line vty 0 4
borisrouter(config-line)#login local
borisrouter(config-line)#exit
borisrouter(config)#username ccna password ciscoAUX
16. 포트 비밀번호 설정
borisrouter(config)#line con 0
17. 타임아웃 안걸기
borisrouter(config-line)#no exec-timeout
18. RIP 라우팅 프로토콜
borisrouter(config)#router rip
19. RIP 라우팅 프로토콜 확인
borisrouter#show run
18. RIP 라우팅 프로토콜
borisrouter(config-router)#network 10.10.10.0
19. RIP 라우팅 프로토콜 확인
borisrouter#show ip protocol
borisrouter#show ip router
20. IP 라우팅 제거
borisrouter(config)#no router rip
21. RIP 디버깅 시작
borisrouter#debug ip rip
22. RIP 디버깅 종료
borisrouter#no debug all
borisrouter#undebug all
23. IGRP Bandwidth설정
borisrouter(config)#int s 0
borisrouter(config-if)#bandwidth 56
24. IGRP 설정
borisrouter(config)#router igrp 200(AS번호)
borisrouter(config-router)#network 10.10.10.0
borisrouter#undebug all
25. IGRP 지우기
borisrouter(config)#no router igrp
26. IGRP 최대 홉 변경(옵션)
borisrouter(config)#router igrp 200
borisrouter(config-router)#metric maximum-hops 255(최대)
27. Passive Interface설정
borisrouter(config-router)#passive interface fa 0/0
28. IGRP 디버깅 시작
borisrouter#debug ip igrp transactions
29. IGRP 디버깅 종료
borisrouter#no debug all
borisrouter#undebug all
30. OSPF 설정
borisrouter(config)#router ospf 100
borisrouter#show ip ospf interface
borisrouter(config-router)#network 172.16.10.0 0.0.0.255 area 0
borisrouter#show ip ospf neighbor
borisrouter(config-router)#network 192.168.12.0 0.0.0.15 area 0
31. OSPF 디버깅 시작
borisrouter#debug ip ospf events
borisrouter#debug ip ospf adj
32. OSPF 디버깅 종료
borisrouter#undebug all
33. IPX 라우팅 정의
borisrouter(config)#ipx routing [4.4.4]
borisrouter(config)#int fa 0/0(encap은 한쪽만 설정)
borisrouter(config-if)#ipx network 1818 encapsulation sap
borisrouter(config)#int s 2/0
borisrouter(config-if)#ipx network 1400
34. IPX 상태 보기
borisrouter#show ipx interface fa 0/0
35. IPX 라우팅 테이블 보기
borisrouter#show ipx route
36. 파일서버 연결 상태 보기
borisrouter#show ipx server
37. 기본 ACL 목록 등록
borisrouter(config)#access-list 1 permit 10.100.10.0 0.0.255.255
borisrouter(config)#access-list 1 deny 10.1000.10.50
borisrouter(config)#access-list 1 permit any
38. 인터페이스에 ACL적용
borisrouter(config)#int fa 0/0
borisrouter(config-if)#ip access-group 1 in
borisrouter(config-if)#ip access-group 1 out
39. ACL 적용 상태 보기
borisrouter#show ip interface fa 0/0
40. ACL 목록 보기
borisrouter#show ip access-lists
41. 텔넷포트에 ACL 적용
borisrouter(config)#line vty 0 4
borisrouter(config-line)#access-class 1 in
42. 확장 ACL 목록 등록
borisrouter(config)#access-list 101 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
borisrouter(config)#access-list 101 permit ip any any
borisrouter(config)#access-list 101 permit ip 0.0.0.0 255.255.255.255 131.108.5.17 0.0.0.0
borisrouter(config)#access-list 101 permit ip any 131.108.5.17 0.0.0.0
43. ACK나 RST bit가 set되면
borisrouter(config)#access-list 104 permit tcp any 128.88.0.0 0.0.255.255 established
44. 텔넷 막는 ACL 설정
borisrouter(config)#access-list 101 deny tcp 150.100.2.0 0.0.0.255 150.100.1.0 0.0.0.255 eq
45. telnetFTP막는 ACL 설정
borisrouter(config)#access-list 101 deny tcp 150.100.2.0 0.0.0.255 150.100.1.0 0.0.0.255 eq ftp-data
borisrouter(config)#access-list 101 deny tcp 150.100.2.0 0.0.0.255 150.100.1.0 0.0.0.255 eq ftpHSRP
46. 그룹 및 가상 IP설정
borisrouter(config-if)#standby 1 ip 172.70.100.1
borisrouter#show standby우선순위(수치큰게 active)
borisrouter(config-if)#standby 1 priority 105
47. Active 복귀시간 지정
borisrouter(config-if)#standby 1 preempt delay 5
48. IF죽으면 우선순위10다운
borisrouter(config-if)#standby 1 track serial2 10
49. Active 변경 시간 지정
borisrouter(config-if)#standby 1 timers 3 10 (3초마다 확인해서 10초이내 대답 없으면 Active됨)
50. 디버깅 설정
borisrouter#debug standby
51. 디버깅 해제
borisrouter#undebug all
52. IP NAT 설정
borisrouter(config)#ip nat pool ccie 210.98.100.2 210.98.100.254 netmask 255.255.255.0
53. NAT 설정
borisrouter(config)#ip nat inside source list 1 pool ccie (inside측 source주소가 ACL 1에 걸리면 ccie Pool 적용)
54. NAT 고정으로 설정
borisrouter(config)#ip nat inside source static 10.1.1.100 210.98.100.100
55. ACL로 inside local 지정
borisrouter(config)#access-list 1 permit 10.1.1.0 0.0.0.255
56. Inside Local로 IF설정
borisrouter(config)#int fa 0/0
borisrouter(config-if)#ip nat inside
57. Inside Global로 IF설정
borisrouter(config)#int s 2
borisrouter(config-if)#ip nat outside
58. NAT 동작 확인
borisrouter#show ip nat translations
59. 디버깅 켜기
borisrouter#debug ip nat
60. 디버깅 끄기
borisrouter#undebug all
61. Setup Mode 가기
borisrouter#setup
62. User Mode에서
borisrouter>enable
63. Privileged Mode에서
borisrouter#config terminal
64. Configuration Mode에서
borisrouter(config)#exit
65. 다시 User Mode로 가기
borisrouter#disable
66. 라우팅 테이블
borisrouter#show ip route
67. 라우터 기본 정보
borisrouter#show version
68. 모든 인터페이스 정보
borisrouter#show interface
69. 이더넷 인터페이스 정보
borisrouter#show interface ethernet 0
70. 시리얼 인터페이스 정보
borisrouter#show interface serial 0
71. 현재 구성 파일
borisrouter#show running-config
borisrouter#write terminal
72. NVRAM 백업 구성 파일
borisrouter#show startup-config
borisrouter#show config
73. 플래쉬 메모리
borisrouter#show flash
74. 라우터 동작 상태
borisrouter#show processes cpu
75. 배너 입력하기
borisrouter(config)#banner motd #
borisrouter(config)#banner motd # This is end #
76. 인터페이스 설명
borisrouter(config)#int fa 0/0
borisrouter(config-if)#description Text
77. Secondary IP 설정
borisrouter(confug-if)#ip address 203.240.150.1 secondary
78. Back-to-Back 구성
borisrouter(config)#int s 0
borisrouter#show controller serial 0
79. 기록 명령 개수 설정
borisrouter#terminal history size 30
80. 서브넷 맨앞 주소 사용
borisrouter(config)#ip subnet-zero
81. DNS설정
borisrouter(config)#ip name-server 168.126.63.1
82. TFTP서버 돌리기
borisrouter(config)#tftp-server flash c800-g3-mw.120-3.T1
83. IOS TFTP에서 가져오기
borisrouter#copy tftp flash
84. 라우터 전체 CDP 금지
borisrouter(config)#no cdp run
85. 라우터 전체 CDP 동작
borisrouter(config)#cdp run
86. 특정 IF의 CDP 금지
borisrouter(config)#int serial 0/0
borisrouter(config-if)#no cdp run
87. 특정 IF의 CDP 금지
borisrouter(config-if)#cdp run
88. CDP 동작 상태 보기
borisrouter#show cdp
89. 연결된 시스코 장비 보기
borisrouter#show cdp neighbors
90. 연결된 시스코장비 자세히
borisrouter#show cdp neighbors detail
borisrouter#show cdp entry *
91. CDP 트래픽 보기
borisrouter#show cdp traffic
92. 단순형 핑
borisrouter#ping 150.10.1.1
93. 확장형 핑
borisrouter#ping
94. Trace
borisrouter#trace 150.10.1.1
95. DHCP 사용
borisrouter(config)#service dhcp
borisrouter(config)#ip dhcp pool ccna
borisrouter(dhcp-config)#network 210.240.10.0 255.255.255.0
borisrouter(dhcp-config)#default-borisrouter 210.240.10.1
96. DHCP Pool 할당 제외
borisrouter(config)#ip dhcp excluded-address 210.240.10.1
97. DHCP 할당 내역 보기
borisrouter#show ip dhcp binding
98. 라우터의 DHCP 상태 보기
borisrouter#show ip dhcp server statistics
이상으로 네트워크 Cisco L3에 대해 정리해보았습니다. 감사합니다.
참고문헌
https://networking.ringofsaturn.com/Cisco/ciscocommandguide.php
댓글
댓글 쓰기